No driver's side indicators working on 69 reg Sandero - Dacia Sandero Forum - Dacia Forum

Jump to content



News Feed


View All Updates


Photo

No driver's side indicators working on 69 reg Sandero


  • Please log in to reply
7 replies to this topic

#1
FallFromGrace

FallFromGrace

    Advanced Member

  • Member
  • 53 posts
  • LocationUK
  • Vehicle Driven:Sandero 2019 (TCE90)

Morning! I've just got in my car for the first time today and I noticed when opening the car that the driver's rear indicator wasn't working..........it turns out the none on the driver's side are working (rear, side and front) 

 

Is this an easy fix? Or do I need to take a fiver's worth of petrol to it? biggrin.png

 

Thanks in advance :) 



#2
Camden

Camden

    Advanced Member

  • Member
  • 210 posts
  • LocationLondon
  • Vehicle Driven:Sandero Access
You could call out Dacia assist as the car is disabled.

John

#3
FallFromGrace

FallFromGrace

    Advanced Member

  • Member
  • 53 posts
  • LocationUK
  • Vehicle Driven:Sandero 2019 (TCE90)
Good idea John. I'll give them a ring tomorrow 😁

#4
Camden

Camden

    Advanced Member

  • Member
  • 210 posts
  • LocationLondon
  • Vehicle Driven:Sandero Access
They operate 24 hours a day.

John

#5
FallFromGrace

FallFromGrace

    Advanced Member

  • Member
  • 53 posts
  • LocationUK
  • Vehicle Driven:Sandero 2019 (TCE90)
I've fixed it! Turned the car over a couple of times and gave the indicator stalk a wiggle.....indicators are working.

#6
Roger

Roger

    Advanced Member

  • Premium Member
  • 3901 posts
  • LocationDudley, West Midlands. UK
  • Vehicle Driven:2013 (63) Sandero Stepway Laureate dCi 90 in Azurite Blue. Supplied with a full size 5 spoke spare wheel & tyre with a 80 km/h sticker ! Now driving with a permanently lit dashboard !
  • My Fuel Logs
    Average MPG: 50.23

I've fixed it! Turned the car over a couple of times and gave the indicator stalk a wiggle.....indicators are working.

Keep an eye on it, before your warranty expires, faulty stalks are not uncommon ! ohmy.png


  • Agree x 1

My Stepway ? I'm lovin' it !! :D  :D 


#7
FallFromGrace

FallFromGrace

    Advanced Member

  • Member
  • 53 posts
  • LocationUK
  • Vehicle Driven:Sandero 2019 (TCE90)
Oh joy! I'll keep switched on. Would some electrical spray/wd40 help keep contacts clean?

#8
Daedalus

Daedalus

    Advanced Member

  • Member
  • 1514 posts
  • LocationSheffield
  • Vehicle Driven:2013 Sandero Ambiance 1.2

From people who have dismantled faulty stalks the failure is due to wires breaking not the contacts. I would not spray it while under warranty or the dealer cold claim, "you messed about with it so warranty is void".


  • Agree x 1




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users