Black screen instead of maps - Stepway Electrical - Dacia Forum

Jump to content



News Feed


View All Updates


Photo

Black screen instead of maps


  • Please log in to reply
3 replies to this topic

#1
doroteapuz

doroteapuz

    Newbie

  • Member
  • 2 posts
  • LocationCroatia
  • Vehicle Driven:Sandero Stepway

Hi guys, new here. I'm kinda desperate cause i have been dealing with this for several months now. I bought a Sandero Stepway from 2013, with full map of Europe, but it only worked for like a month. Anyways, first the Accept button was greyed on navi and my clock was all messed up, the minutes were fine but it showed it was 2 hours less than it actually was. Went to an authorized service about that, but they were all just condescending and acting like it isn't a problem, like i am just stupid and don't know how to set the time, would not even look at the car. Did my fair share of research and updated the media nav from 2.0.6 to 2.0.9. Now the clock works fine, i can press the accept button, but when i do, it is just a black screen, all i can do is press the bottom left corner and it goes to the home page. Please help. I have worked for 4 years alongside uni to buy this car. Thanks for all the tips!



#2
NeeK

NeeK

    Advanced Member

  • Member
  • 97 posts
  • LocationUndeva
  • Vehicle Driven:Dacia Duster 4x4 110HP Laureate 2017

@doroteapuz

It seams you have a MediaNav MN1 Standard. The clock is adjusted itself trough GPS if works. Having grey the Accept button GPS was not working and in consequence also the date and hour is not updating correctly.

What is strange for me is how you upgrade it to 2.0.9, because it's last version is 4.1.0 available in official sites?

The button grey for Accept is becasue the license is not matching with the maps inside.

In last time, I receive many of MN1 with memory problem for fix. It's seams the NAND memory arrived at end of life. 



#3
doroteapuz

doroteapuz

    Newbie

  • Member
  • 2 posts
  • LocationCroatia
  • Vehicle Driven:Sandero Stepway

I searched all over the internet and managed to find an upgrade file for 2.0.9 (it was at 2.0.6) and hoped for the best. I'll try and upgrade it to 4.1.0 today and hopefully something happens. The Accept button works now, but its like the nav card burned out and even the maps that were inside (and worked when i first bought the car) have been wiped. It's a problem beacuse when i accept, i cannot copy the existing files to a usb drive so i can restore it via toolbox. It is just a black screen...



#4
NeeK

NeeK

    Advanced Member

  • Member
  • 97 posts
  • LocationUndeva
  • Vehicle Driven:Dacia Duster 4x4 110HP Laureate 2017

@doroteapuz

 

Here you have the latest firmware version for your MediaNav:

 

MediaNav Standard 4.1.0
4.1.0 - 2018041201_Renault_Dacia_OS_Update

 

Take a good brand of USB (if possible SanDisk) max 32GB.

Format this USB as FAT32 and extract this archive directly to this USB.

With this USB go to car, START engine, wait a minute (give a little volume to radio) and insert USB. Accept and wait to finish the upgrade.

Do not stop engine or remove USB until the sound of radio come back and check version again. Must be in 4.1.0.

So like this you will be in last version. biggrin.png

If you need other help, let me know.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users