UK Dacia Forum banner
1 - 20 of 51 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Been at the manufacturers service 4 times already. The mistake reported concerns different problems with fuel injecton and pressure. After all the checking and reprograming they still don't know what is the problem and there is no mention of an ESP fault in computer. Any of you had a similar problem. Duster is diesel 2015, 4wd with 160k km.
 

·
Registered
Joined
·
2 Posts
Hi, just had a similar experience with my 2014 diesel 4WD Duster. The red warning light for a critical electrical fault came on at the same time as the orange electronic stability programme warning light, the engine began to run roughly so I pulled over and stopped. I left it for a minute or two, started up again and it ran perfectly, so I drove home (about 30 miles). So far I haven't taken it to a garage to diagnose the fault so I can't say what the trouble was. Hoping someone can share a similar experience, but I will post again once I have some answers.
 

·
Registered
Joined
·
44 Posts
FWIW. My brand new Stepways electronic and check engine light have flashed for around 20secs on two separate occasions. The code DTC code I get is a random misfire but the engine is fine and nothing seems wrong. I'm thinking it's an electrical fault.

Sent from my GM1913 using Tapatalk
 

·
Registered
Joined
·
2 Posts
I have had the same issue, started about a month ago, Esp and electric fault light came on for a few seconds then went off, took it for a diagnostic and found no codes. Been OK for 3 weeks and now the issue has started again, Monday it came on and off 3 times within 5 minutes of starter my journey, then it was fine for the rest of the journey 60 mile drive. Drove 68 miles Tuesday, no issues, took it out Tuesday night and again the lights came back on for a few seconds within 10 minutes of driving, then no issue for the rest of the journey.
 

·
Registered
Joined
·
5 Posts
I have had the same problem with my 2014 Duster.(diesel 4wd) When these lights come on there is a reduction in power. It is impossible to go faster than 65 to 75 mph and there is a huge reduction in torque.Around town it is not really noticeable but shows up more on long inclines where the lack of torque becomes evident. These lights tend to come on when driving with light throttle at around 50 mph or so. The fault codes seem to indicate a problem with injector rail pressure.
To date the following has been rectifications have been implemented but to no avail
Fuel filter replaced
rail pressure adjusted
new manifold heater plugs fitted
injectors and Dpf filter cleaned
When the lights come on if the vehicle engine is stopped for a short time(seconds) and restarted these lights go out and full power is restored. The vehicle can then go 100 to 200 or sometimes many more miles plus miles before it happens again.
Anyone got any ideas? Is it just a electrical fault with the system?
The vehicle was bought new to tow my small caravan but with this problem it as not safe to attempt towing due to the reduction on power and torque
 

·
Registered
Joined
·
7 Posts
Having the same problem with my 18 plate 1.6 Duster. Nothing I do has fixed it. I can reset the PAS and the lights go out but next time I switch her off and on again the lights are back.
 

·
Registered
Joined
·
52 Posts
Hello everyone, not been here in a long time.

I have a problem when my Dokker 1.6 MPI is packed full or pulling my trailer, it stutters and i get no more than 500 rpm.

This does not last long and combated by stopping, turning the Engine off and carrying on. The Engine fault light comes on and stays on for about 100 miles then is gone.

Most annoying as it only happens when i am trying to catch a Ferry home from across the water !!!

Anyone had similar issues ?

I am just about to change the Air Filter and spark plugs just to be sure there are no problems there and perhaps the HT leads as well ?

Oh and what are the correct sparkplug gaps as i can not find them anywhere please ?

Thanks.
 

·
Registered
Joined
·
5 Posts
Hi all. Exactly the same issue. Due in with main dealer Thursday will post results but from above I'm not encouraged.. Duster 2015 4x4 89000 kms 1.5dci. Low power esp and critical control light.
 

·
Registered
Oct 2013 Sandero Ambiance 1.2
Joined
·
2,428 Posts
It is very rare people post the resolution of their problem on this forum.

It may even be you have an electric fault with the ESP module as the warning lights indicate!

There are five ( six on later cars where the radio is on the Canbus ) electronic modules. The ESP module is in front of the gear stick and has accelerometers ( like smart phones ) to detect the motion of the car.
 

·
Registered
Joined
·
7 Posts
Mine went in to the dealer, Arnold Shark, and the looked it up on the computer and found the fault straightaway. They told me they reset the ESP ECU and it hasn't done it since.
 

·
Registered
Joined
·
1 Posts
only had my 2017 4x4 1.5 diesel prestige 6 weeks and the abs and esc lights have been coming on intermittently but now they have stayed on for the last 2 days. i have had the car back to the garage and they cleared the lights with the diagnostic computer but they have come back on again. the car has only done 13000 miles. any ideas guys.?
 

·
Registered
Joined
·
2 Posts
Hi, I've got exactly the same problem with my 17 plate duster 4x4 prestige. Mines has been back to the local dealer a few times. Our Esp and Electronic warning lights come on for around 5 seconds, coupled with no power. After this the lights go out and power is restored.

The dealer says it's shows 'low voltage' on the fault reader. I've put a new battery which seemed to clear the fault for around 6 weeks but it's returned. Happens most journeys.

The dealer says they can't find it and doesn't want to see the car again even though I have an extended warranty.

I'm watching this thread!!!
 

·
Registered
Oct 2013 Sandero Ambiance 1.2
Joined
·
2,428 Posts
The Duster 2 has an EMM ( energy management module ) and smart alternator, Seeing replacing the battery temporarily cured the fault suggests a charging problem does it not. Have they not replaced either?
 

·
Premium Member
Azurite Blue Sandero Stepway dCi 63 plate (2013) with permanent dashboard illumination.
Joined
·
4,259 Posts
Hi, I've got exactly the same problem with my 17 plate duster 4x4 prestige. Mines has been back to the local dealer a few times. Our Esp and Electronic warning lights come on for around 5 seconds, coupled with no power. After this the lights go out and power is restored.

The dealer says it's shows 'low voltage' on the fault reader. I've put a new battery which seemed to clear the fault for around 6 weeks but it's returned. Happens most journeys.

The dealer says they can't find it and doesn't want to see the car again even though I have an extended warranty.

I'm watching this thread!!!
Have a word with Dacia Customer Relations on 0344 335 1111 and see what they suggest, it needs to be sorted.
ohmy.png
 

·
Registered
Joined
·
2 Posts
The Duster 2 has an EMM ( energy management module ) and smart alternator, Seeing replacing the battery temporarily cured the fault suggests a charging problem does it not. Have they not replaced either?
Nope. All they have done is pulled all the connector plugs on the wiring harness apart and put them back together again.
 

·
Registered
Joined
·
2 Posts
Hello guys, looks like I am not only one having issues with Duster II. 3 times (randomly) just turned off with plenty of error (first error was electric circuit issue, second ESP, ABS, Steering wheel and etc) and after this turning off I cannot start my car, like imobilizer would be blocked. I have start-stop system, not simple key. So three times I just took off (-) from battery and put it back. After this procedure I can start my car, but got all same errors on dashboard. I driven my duster to local dealership to find issue for this problem, but they cannot find anything we got agreement that next time when car will turn off I call 24/7 help and bring my car to their service to find issue. Anyone had this too??
 

·
Registered
Joined
·
1 Posts
Hi, just had a similar experience with my 2014 diesel 4WD Duster. The red warning light for a critical electrical fault came on at the same time as the orange electronic stability programme warning light, the engine began to run roughly so I pulled over and stopped. I left it for a minute or two, started up again and it ran perfectly, so I drove home (about 30 miles). So far I haven't taken it to a garage to diagnose the fault so I can't say what the trouble was. Hoping someone can share a similar experience, but I will post again once I have some answers.
Hi , just wondering have you had any answers? Having same problem. It happened a few weeks ago where it came on but went after I restarted the car but now this week its on constantly, sometimes losing power or not picking up speed. It constantly beeps. Sometimes it will turn off for a few minutes while driving but happens again. Garage think it might be fuel injectors and I need a new steering rack.. mine is also a 2015 4wd.
 
1 - 20 of 51 Posts
Top