UK Dacia Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
225 Posts
Discussion Starter · #1 ·
Traction control on the logan mcv ??

does it exist ?

my car is spinning loads on junctions etc not used to this heavy foot maybe but its only 900cc so is this another issue for the dealer the list is growing and still they wont answer emails I may have to phone or turn up, they will love that am sure.
 

·
Registered
Joined
·
1,786 Posts
Traction control on the logan mcv ??

does it exist ?

my car is spinning loads on junctions etc not used to this heavy foot maybe but its only 900cc so is this another issue for the dealer the list is growing and still they wont answer emails I may have to phone or turn up, they will love that am sure.
probably will if you've got a bootful of bricks??? What are your tyre pressures at? Sometimes the dealer sets the pressure too high and causes loss of grip
 

·
Premium Member
Joined
·
225 Posts
Discussion Starter · #3 ·
have not seen it light except when starting car off ignition, so not sure

tyre pressures are correct

will kepp monitoring but its on the list if the dealer ever decides to email me back.
 

·
Registered
Joined
·
985 Posts
My duster's isn't working either. The dealer claims that the traction control and ABS aren't working due to the All Terrain tyres. I've got customer services on the the case.

Sent from my A0001 using Tapatalk
 

·
Registered
Joined
·
1,786 Posts
have not seen it light except when starting car off ignition, so not sure

tyre pressures are correct

will kepp monitoring but its on the list if the dealer ever decides to email me back.
Mine seems to be ok big neil, I've not had it light up either though.
Mines a fairly early model, it possibly doesnt even have it.
On the plus side if your getting all that power from new, god help you when it's fully bedded in, mine was a bit jerky and picky about when it wanted to pick up the power when I first got it.
 

·
Registered
Joined
·
175 Posts
I pulled out of a junction that was wet and greasy (possibly diesel or oil spilled) and mine spinned the wheels freely with no tc kicking in causing judder, don't remember seeing a light either. Doubt it actually has working tc to be honest
 

·
Registered
Joined
·
425 Posts
The traction control (ASR), ABS and ESC are all part of the same system. The hydraulic pump is certainly present on mine bolted to the near side bulkhead. An operating system does not cause the judder that is felt through the brake pedal when ABS operates. It uses combination of engine torque reduction, by various methods and reducing or increasing hydraulic pressure to one or more brakes. It is difficult to test without snow and ice to play with. Don't forget these systems can not change the laws of physics and it may have been operating, their first function is to keep you going in the direction indicated by steering wheel position. I have not encountered the conditions to tell if mine works, but they are supposed to run self tests and light the warning light if anything fails.
How to test if the systems are working..you try first to see if yours is working.. :p

 
1 - 7 of 7 Posts
Top