UK Dacia Forum banner
1 - 20 of 33 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
Well I ordered my White Logan Laureate TCe90 in August and was promised delivery early November and it duly arrived today! Can't fault Arnold Clark Paisley for their customer service. Only driven it home tonight, very carefully in the torrential rain! So far so good. Will report more fully when I've had a proper drive in it!
 

·
Registered
Joined
·
1,396 Posts
Nice one, Ayrshiretiger, can't wait to see it! Be nice to see one with a "local" reg, too (Ayrshire born-and-bred)
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #9 ·
Hmmm, having had a quick look it does look like condensation. What is the likely cause and what is the solution? I'm guessing best thing to do is take it back to dealer?
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #11 ·
Hmmm....from owners handbook..."Operating Faults...Traces of condensation in lights...This is not a fault. Traces of condensation are a natural phenomenon caused by variations in temperature. These traces soon disappear when the lights are switched on".

Will keep an eye on it!
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #12 ·
You're right nss, I probably wouldn't even have noticed if Geraint hadn't pointed it out (although I do appreciate it being flagged up!).
 

·
Registered
Joined
·
39 Posts
Congratulations and enjoy!

Look forward to your thoughts and impressions.

Ours should arrive in a week or so, can't wait! Ours will be white too, so at least I now know what it will look like! :)
 

·
Registered
Joined
·
1,263 Posts
Congratulations and enjoy!

Look forward to your thoughts and impressions.

Ours should arrive in a week or so, can't wait! Ours will be white too, so at least I now know what it will look like! :)
With the white being so popular and arguably one of the best colours I wonder how long before Dacia do what every other dealer does and start charging for it
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #15 ·
Another point....... if both lights are the same then it is probably weather related. If it was the one light i personally believe the cap on the back is to blame
I had it on my alfa because the plastic cap on the back wasnt on right. A way to cure it is to take cap off and very gently heat the front of the light with a hairdryer on low/half heat setting until all the moisture has evaporated. When the light cools down completely put the plastic cap back on and it should be problem solved. It probably has misted up because the headlights were on and hot for the 1st time, and the rain you were driving through was cold......... check it today and it might have gone by itself
Yes, was both headlights so no doubt due to conditions/newness. Seems ok today. Thanks for the advice everyone :)
 
1 - 20 of 33 Posts
Top