UK Dacia Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
Since we collected our Duster, which is lovely btw, we have had issues with our multimedia device!
Started off with the telephone keypad and DVD not working. After I spoke with Kenwood about it and found out the possible problem I told the garage that they had forgotten to connect the 'parking brake' wire. This basically stops the above things working while driving. That's fine and was sorted.
Having done this another problem has materialised in as much as the microphone for the voice recognition not working. I spoke to Kenwood again who had no idea so back to garage. They check it again, everything's connected so should be fine, but it's not!! Meant to have phoned us back Tuesday. No call. Wife phones Wednesday. Garage waiting for kenwood to contact. No apologies for having not phoned of course. Nothing Thursday. Today after wife phones again they say that kenwood technical guy coming and we can have courtesy car while it's being looked at but no idea when they're coming yet!
Do I hold any hope? No. Is customer service any good. Definitely not!
Paid £500 for this kenwood device and it's been problem after problem!! Will they ever sort it!!!
 

·
Registered
Joined
·
1,263 Posts
Me thinks your now fully entitled to demand your cash back; they have had time to carry out a repair and failed; Don't let them try to fob it off on to Kenwood it's down to them to sort it as they fitted it' feel free to name and shame
 

·
amazing, just amazing!
Joined
·
2,926 Posts
If the dealer supplied the Kenwood I'd be looking to them for a replacement or refund.
 
1 - 4 of 4 Posts
Top