UK Dacia Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Had a test drive today in a Duster and the seatbelt alarm going off. Only me and the passenger are both wearing our seatbelts... so I pull over and take my belt off and put it on again (as does the passenger) we set off and it happens again so I hold down the buckle and it stops. A little while later it starts again and even holding it down it continues for the rest of the journey.

Anyone else seen this? Are we maybe seeing the Renault influence in the wiring? If the duster ends up with writing like the old shape Megane (with those backside adverts) I'll be going somewhere else as the electrics on those Meganes constantly fail.

For now I'm just going to take it as a one off and I actually thought the drive was actually quite good.
 

·
Registered
Joined
·
560 Posts
Hi Chuffy

I had no problem on the test drive. Did you have a salesman with you? Or mention it on your return?

If not then if possible a return visit may be in order to find if they sorted it and what the remedy was. I can't see them leaving a problem like that on demo for long.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
I had no problem on the test drive. Did you have a salesman with you? Or mention it on your return
Indeed I did, she seemed genuinely shocked and it went straight into the workshop when it got back. Seemed like a fault with a connection somewhere preventing it detecting that the belt was fastened. I don't know what it turned out to be so I'll probably email her to find out.
 

·
Premium Member
Joined
·
1,199 Posts
7 year warranty, that's what I'll be doing
 
1 - 6 of 6 Posts
Top