UK Dacia Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
How do you switch on the radio , i suspect i have a dud unit or a loose connection , holding the left button down nothing , pressing the button nothing , checked fuse looked ok and replaced anyway.Used pull tools to get it out , one side rh wont disconect so cant remove and check for another inline fuse of dodgy connection,Its a left hooker single din if that makes any difference.

tia
 

·
amazing, just amazing!
Joined
·
2,926 Posts
Not sure what radio is in yours? but you do have the ignition on while trying don't you?
 

·
amazing, just amazing!
Joined
·
2,926 Posts
Looks like the knob on the right is the one. How do you stand with warranty, can you get the radio checked easily?
 

·
Premium Member
Joined
·
2,815 Posts
just push the left round button on it

or if it doesnt work

see if it has a source button

but i think its the first option that should do it (or maybe its has a fuse problem afterall)
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #6 ·
Dropped off at PARKS IRVINE , 5 mins diagnose a fuse problem right enough , not a blown one but one that that was taken out for transit and not put back in.

So if anyone has a similar problem , well on a left hand drive duster , here was the symptoms..

Radio no power ,screen heater switch light bulb no power - but switch worked as shown on the dials cluster , over head cab light no power...they may have been other secondary lack of power somewhere else but these I never noticed.
 

·
amazing, just amazing!
Joined
·
2,926 Posts
Good news it was a simple fix, now you can get down to some serious brilling :D
 

·
Registered
Joined
·
268 Posts
Dropped off at PARKS IRVINE , 5 mins diagnose a fuse problem right enough , not a blown one but one that that was taken out for transit and not put back in.

So if anyone has a similar problem , well on a left hand drive duster , here was the symptoms..

Radio no power ,screen heater switch light bulb no power - but switch worked as shown on the dials cluster , over head cab light no power...they may have been other secondary lack of power somewhere else but these I never noticed.
LOL, mine was the same. I was nosing around the car just after it had been delivered to the dealer and none of the above were working, I rushed into the showroom and told the salesman that my new car is a dud and that I don't want it with these faults.

He just laughed at me, then nochalantly walked out to the car, fished the fuse out of the ashtray and fitted it in the fusebox.

Boy, did I feel a plonker. :( B)
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #9 ·
Boy, did I feel a plonker. :( B)

not as much as I did later trying to find the dipstick.
 

·
amazing, just amazing!
Joined
·
2,926 Posts
Hey, I've had my Duster since June and I only found the dipstick yesterday after a post by D&M asking!
 

·
Registered
Joined
·
309 Posts
Hey, I've had my Duster since June and I only found the dipstick yesterday after a post by D&M asking!
Knew where it was but it was a heck of a pull to get it out the first time.
 

·
Registered
Joined
·
15 Posts
Hi chaps! I have a similar issue with my 1 year old Duster 1.6 4X2.

Until yesterday, whenever I turned on the engine the radio would turn on automatically. Not any more! :( I have to manually turn it on and if I turn on the A/C, the radio will switch off after a few minutes. Also, the cigarette lighter/power point has stopped working. Could it also be a simple fuse problem? I hope so! :(

Thanks guys!
 

·
Registered
Joined
·
140 Posts
Hi chaps! I have a similar issue with my 1 year old Duster 1.6 4X2.

Until yesterday, whenever I turned on the engine the radio would turn on automatically. Not any more! :( I have to manually turn it on and if I turn on the A/C, the radio will switch off after a few minutes. Also, the cigarette lighter/power point has stopped working. Could it also be a simple fuse problem? I hope so! :(

Thanks guys!
Hi, its a fuse gone. I had the same problem. The radio will turn itself off after 10 mins ( it's not linked to the air con, I think that's a different fuse) . If you look in the fuse box on the passenger side and compare it with the manual you'll spot the radio fuse. There's probably a spare in the fuse box. Easy enough to change over and should work fine, mine did. Cheers
 
1 - 14 of 14 Posts
Top