UK Dacia Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Dacia Duster 2017
The right hand demister connector was inadvertently pulled out and the rear demister stopped working (see pic)

i popped it back into the rubber slot but that didnt work for obvious reasons....

when i pull out the rubber bung that the connector slots into there was nothing for it to connect to!

When inspecting the connector on the left side there is a very obvious cable and connector.

Rooting around with my finger hole (which is very awkward) i couldn't find a cable.

So im wondering if there should be one there ( i assume so) or if it would have been possibly soldered in place?

If it should have a cable - which part of the boot door do you think can i find it and get it back into place?

Thanks in advance!
Sky Plant Wood Shade Sunlight
Wheel Sky Tire Cloud Bicycle tire
 

·
Registered
Oct 2013 Sandero Ambiance 1.2
Joined
·
1,864 Posts
That is a male spade connector which suggests there is a female connector inside and it was not soldered. Have you tried poking about with stiff wire bent with a hook on the end.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
That is a male spade connector which suggests there is a female connector inside and it was not soldered. Have you tried poking about with stiff wire bent with a hook on the end.
Yes i tried that with 30 cm piece of cold steel rod with an end i made into a hook but it felt like it just kept hitting metal. Might try a longer piece and see how that does.
 

·
Registered
Joined
·
202 Posts
There seems to be a sort of clamp at the end of the demister element. I can see it but not photograph it be very well. This is what mine looks like. You can just see the blurry image of it, east of the wire. Looks like brass.


Sent from my moto g(6) play using Tapatalk
 

·
Registered
Joined
·
202 Posts
So like Daedalus says, that male connector looks to go thru the rubber bung, into a female connector behind it.

Sent from my moto g(6) play using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
@Daedalus yep you were right. i pulled out any rubber or plastic plugs in the boot door and finally found the cables down by the lock mechanism. I had to thread it up to the each next hole until i managed to thread it from the final hole with the connector with a long single piece of chicken wire! Thanks for all of the advice guys.
 

·
Registered
Joined
·
202 Posts
How did the wire end up falling to near the lock? Was it dragged down or did it just fall back by gravity?

Sent from my moto g(6) play using Tapatalk
 
1 - 7 of 7 Posts
Top