UK Dacia Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
My wife's Duster started having this issue last year, then it disappeared. It reappeared last week. We travelled to Aberdeen from Edinburgh (no issues). Next day- Aberdeen to Peterhead & back (no issues). It then rained overnight. Travelling back to Edinburgh, we got 40 miles down the road, and the warning lights came on (small loss of power & a slight steering "wobble" issue, but not undrivable. Stopped further down the road- turned engine off & waited 10 mins - restarted - no further issues. I had been playing a game of trying to increase my MPG- started at 41mpg and got up to 43.6mpg.
Next day, travelled through to Glasgow (60miles- no issues) . Returning back the same day, I was still playing my MPG game, and lightly feathering the throttle. I felt a very, very slight loss of engine power through the throttle (like a gust of wind hits you head on) then goes back to normal. I felt this several times over the next 10 miles, then out of the blue on a flat straight section at a speed between 65/70 mph- the warning lights came on. Stopped further on down the road - waited a couple of mins- restarted & had no further issues since.
We have been back through to Glasgow on a one day trip with the car, and to try to stop this I have been altering my throttle pedal position when ( I thought) that i detected the very slight loss in power, but kept the RPM to approx 2500 revs. Thankfully nothing happened on that journey, so the issue did not reappear, or my throttle changes. Both journeys to Glasgow & back were in the dry with no overnight rain.
 
1 - 1 of 1 Posts
Top