UK Dacia Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
When driving our Duster the seat belt warning keeps going off randomly. This happens with either 1 or 2 front passengers. It is not because something is on the seat. The beep lasts about 2 minutes before stopping and just the warning light stays on. The seat belts are correctly fastened and work fine.

Took it into the dealer who could not find a fault. As expected, on the way home it started up again.

Has anyone experienced this? If so, do you know what the cause was?
 

·
Premium Member
Joined
·
38 Posts
It sounds like what we used to call an "intermittent fault". There is a place somewhere in the alarm circuit where it is closing where it shouldn't. Start at the butt sensor wire, usually green and located under the seat. Check the connections for tightness. If the connections are loose, make them tight, and test drive. If they're all tight, unplug it completely and take a test drive. If the alarm doesn't activate, problem solved. You will just have to verbally beep at your passenger until he/she puts on the seatbelt. From there, it's anyone's best guess.
 

·
Registered
Joined
·
27 Posts
Mine is doing this at the moment, I've had a cable replaced already as it has split, pinching between the seat belt clip and the seat frame, but is now doing it again with no visible damage to cable. It's annoying as happens intermittently and not able to replicate it for myself if it's behaving, when it happens it will beep as me for the whole journey even with my belt on! Going back to Renault on Thursday to be left and inspected - fingers crossed they know what it is and can fix it!
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #5 ·
Thanks for your replies.

I will have to look for the wire under the seat HasemBinSober if this is going to stay beeping. I hope my dealer checked the wiring when I took it in - but who knows?

I will be interested to know how you get on Gazza86 and whether your dealer identifies what it is.
 

·
Registered
Joined
·
2 Posts
Hi
i had the same problem...seat belt alarm going off even when all seatbelts were correctly plugged in...
I disconnected the alarm by pulling apart the green connector under the drivers seat...nothing broken, it can simply be pushed back together.
 

·
Registered
Joined
·
1 Posts
My seatbelt sensor keeps going off, even when both front seats are occupied and both front seat people are properly strapped in, it also happens when just the driver is in the car and properly strapped in, it seems to be worse when the outdoor temperature is a hot sunny day
 
1 - 7 of 7 Posts
Top