UK Dacia Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, My media system has gone to a white screen and keeps turning on and off without showing anything on the screen other than s white screen. Has anyone seen this before?. What's the remedy?. Replace the unit or repair it?. Thanks everyone for looking and helping. Suggestions please?. Thanks.
 

·
Registered
Joined
·
115 Posts
This is not usual. What you done before happen this?

Trimis de pe al meu SM-A705FN folosind Tapatalk
 

·
Registered
Joined
·
115 Posts
From which year is your car? Did you changed the unit so far?
Which version is your unit?

Trimis de pe al meu SM-A705FN folosind Tapatalk
 

·
Registered
Joined
·
39 Posts
Hi, My media system has gone to a white screen and keeps turning on and off without showing anything on the screen other than s white screen. Has anyone seen this before?. What's the remedy?. Replace the unit or repair it?. Thanks everyone for looking and helping. Suggestions please?. Thanks.
It sounds like an initialisation issue, hence going on and off as it tries and fails to communicate.
Where in the chain of communication the fault lies needs an analyser to pinpoint, if indeed it can if say there is a cable fault.
 

·
Registered
Joined
·
115 Posts
White screen is one and turn on and turn off other.
I have feeling that your unit is a MN1 old and have problem with memory.
Search a good electronics technician and maybe help you.
Anyway I think maybe is time to change with MN2 or MN3 unit which are better.

Trimis de pe al meu SM-A705FN folosind Tapatalk
 
1 - 6 of 6 Posts
Top