UK Dacia Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
313 Posts
Discussion Starter · #1 ·
I have today taken Gollum in to Roxby Garage Ltd, at Warsash, near Southampton, where they had a look at the yet again faulty windscreen wiper function. The motor was supposedly replaced last August by Sewards of Portsmouth, following the intermittent sweep function going funny and stopping mid-sweep. After Sewards did 'something' and charged hundreds to Dacia for a warranty repair and wipr motor replacement, it seems they simply moved the fault to the fast wipe function instead....

Roxby today tested all the motor functions, and could find no fault on the electrical supply or the switch, relays, wiper arms and 'driver' (that's me!), so they put in a new unit they had ordered in case mine was faulty, and amazingly it worked fine immediately!

I had a good look at the removed motor which was apparently replaced in August, by Sewards, and it was apparent that IF it had been replaced, then it was not a new unit! There is considerable deterioration / corrosion / fatigue showing to the metal arm, and the serial numbers seem to be far older than 2013 part lists would imply they should be. (Unfortunately they haven't come out on the pics, but take my word for it - the dates shown are 2012!!)

As far as Sewards go, I will NOT recommend them to anyone for warranty or servicing, and definitely not buying a car!

Photos of the unit supposedly installed by Seward 4 months ago:
 

Attachments

·
Registered
Joined
·
2 Posts
I have today taken Gollum in to Roxby Garage Ltd, at Warsash, near Southampton, where they had a look at the yet again faulty windscreen wiper function. The motor was supposedly replaced last August by Sewards of Portsmouth, following the intermittent sweep function going funny and stopping mid-sweep. After Sewards did 'something' and charged hundreds to Dacia for a warranty repair and wipr motor replacement, it seems they simply moved the fault to the fast wipe function instead....

Roxby today tested all the motor functions, and could find no fault on the electrical supply or the switch, relays, wiper arms and 'driver' (that's me!), so they put in a new unit they had ordered in case mine was faulty, and amazingly it worked fine immediately!

I had a good look at the removed motor which was apparently replaced in August, by Sewards, and it was apparent that IF it had been replaced, then it was not a new unit! There is considerable deterioration / corrosion / fatigue showing to the metal arm, and the serial numbers seem to be far older than 2013 part lists would imply they should be. (Unfortunately they haven't come out on the pics, but take my word for it - the dates shown are 2012!!)

As far as Sewards go, I will NOT recommend them to anyone for warranty or servicing, and definitely not buying a car!

Photos of the unit supposedly installed by Seward 4 months ago:
I just replaced mine myself , Complete motor and mechanism was £250 , Took me under an hour to do .
 
1 - 5 of 5 Posts
Top